[Stuck] Raven goes missing

Having tech problems? Need a driver? Post them here and do not worry, there is always a solution for you.

[Stuck] Raven goes missing

Postby Jaerin85 » 13 July 2017, 02:31

I recently bought the game on Steam, and I'm loving it so far. But when I choose to go save Arken from the mad orc shaman and come back Raven is gone. When I talk to Spearhead he says they kept Raven on ice for me. Monkey is standing in the middle of the hideout but when I talk to him he warps back up to his ledge and says nothing but "Hi, buddy." I can't get him to bring back Raven so I can progress in the game. I tried installing the 1.0.0.2 patch and restarting the game from the beginning but have the same problem.
So next I tried restarting the game and skipping the orc shaman fight and going with Raven right away. But he just takes me outside the room in the catacombs where I was ambushed and I can't go anywhere. It won't let me go back into the room of the ambush, and when I try to go upstairs there is an invisible wall blocking me from moving up. I've tried restarting the game and reopening the save, the patch and even beginning a new game on different difficulties but whether I fight the shaman or not I'm unable to progress. Please help as I'm loving the game up to this point and would like to complete it.
Jaerin85
 
Posts: 1
Joined: 13 July 2017, 02:20

Return to Technical Forum

Who is online

Users browsing this forum: No registered users and 2 guests

cron